npm downloads
Analyze and visualize download stats for npm packages and authors.
Analyze and visualize download stats for npm packages and authors.
Analyze and visualize download stats for npm packages and authors.
Analyze and visualize download stats for npm packages and authors.
Showing npm packages maintained by this author. Pick a package to open detailed download analytics.
EditorConfig File Locator and Interpreter for Node.js
Parse EditorConfig-INI file contents into AST
Read and write a growable buffer as a stream
Encode and parse data in the Concise Binary Object Representation (CBOR) data format (RFC8949).
Parser generator for JavaScript
Encode and parse data in the Concise Binary Object Representation (CBOR) data format (RFC8949).
Generates source maps
Load a string as if it was an esm or commonjs module with a given filename.
Encode and decode [WTF-8](https://simonsapin.github.io/wtf-8/) with a similar API to [TextEncoder](https://developer.mozilla.org/en-US/docs/Web/API/TextEncoder) and [TextDecoder](https://developer.mozilla.org/en-US/docs/Web/API/TextDecoder).
Parse and generate RS-delimited JSON sequences according to draft-ietf-json-text-sequence
Node's util.inspect, extracted for use on the Web
Quick wrapper that finds TextDecoder in your runtime, or uses an adequate polyfill
This package bundles the [cbor](../cbor) package for easy use on the web. The following packages are bundled in as well, to reduce the degree of difficulty:
Plugin for node-cbor to add BigDecimal and BigFloat support. Requires bignumber.js
DNS over HTTPS and DNS over TLS
Runtime code for unicode-trie files.
Unicode line-breaking algorithm from UAX #14
Augmented Backus-Naur Form (ABNF) parsing. See RFC 5234.
hildjj's lint rules
Node.js Module for parsing .pcapng files and tcpdump output.
Lint rules for peggyjs projects
React Native pre-requisites for cbor
Get width of a Unicode string in fixed-width display cells, accounting for combining characters, emojis, flags, Hangul, East Asian Width, default ignorables, and a few more.
Extract fields from package.json into an ES6 module
Wrap lines using the Unicode Line Breaking algorithm from UAX #14
Small utils useful across all of my projects.
Evented parser based on a WASM-compiled version of expat
Description
Parse CBOR Extended Diagnostic Notation as defined by [draft-ietf-cbor-edn-literals-16](https://www.ietf.org/archive/id/draft-ietf-cbor-edn-literals-16.html) and some CBOR working group discussions.
A thin wrapper around [Pino](https://getpino.io/#/) to insulate multiple projects from the dependency, and to normalize a common pattern in those projects.
Command line tools to encode and parse data in the Concise Binary Object Representation (CBOR) data format (RFC8949).
Testing-only Certificate Authority (CA) for your local development environment ONLY. This is in no way suitable for production of any kind.
Serve files from a directory over HTTP/1.1 and HTTP/2, with live reload notifications over a websocket. It will automatically create self-signed certificates.
Interface to websequencediagrams.com
Grunt task for generating Codo documentation
Ensure eslint all rules are sorted, not deprecated, and included
Up the code coverage on your [Peggy](https://peggyjs.org/) grammars, ensuring that the generated boilerplate code is covered in your unit tests. This makes it easier to find places in your grammar that actually need to be tested.
Mock up a plain or TLS-encrypted TCP connection without using any actual network facilities or needing any permissions. This is useful for testing, particularly playing around with different TLS failure modes.
(in)dent XML to make it pretty
Builder code for unicode tries
ESLint-style parser for Peggy grammars
An [eslint](https://eslint.org/) plugin to check [peggy](https://peggyjs.org) grammars.
Scaffold a new project in the `@cto.af` style.
Parse HTTP headers from RFC 9110 (and a bunch of others) using the full ABNF.
feedly.com API
This project is a relatively-simplified approach to publishing multiple NPM packages from a monorepo. It handles these use cases:
`peggy-tracks` creates railroad track diagrams of [peggy](https://peggyjs.org/) grammars.
Download, cache, and parse files from the Unicode Character Database (UCD).
DNS over HTTPS and DNS over TLS
Create a mock DNS-over-TLS server based on [mock-tls-server](https://github.com/hildjj/mock-tls-server/).
Showing 50 of 84 packages
Analyze and visualize download stats for npm packages and authors.
Showing npm packages maintained by this author. Pick a package to open detailed download analytics.
EditorConfig File Locator and Interpreter for Node.js
Parse EditorConfig-INI file contents into AST
Read and write a growable buffer as a stream
Encode and parse data in the Concise Binary Object Representation (CBOR) data format (RFC8949).
Parser generator for JavaScript
Encode and parse data in the Concise Binary Object Representation (CBOR) data format (RFC8949).
Generates source maps
Load a string as if it was an esm or commonjs module with a given filename.
Encode and decode [WTF-8](https://simonsapin.github.io/wtf-8/) with a similar API to [TextEncoder](https://developer.mozilla.org/en-US/docs/Web/API/TextEncoder) and [TextDecoder](https://developer.mozilla.org/en-US/docs/Web/API/TextDecoder).
Parse and generate RS-delimited JSON sequences according to draft-ietf-json-text-sequence
Node's util.inspect, extracted for use on the Web
Quick wrapper that finds TextDecoder in your runtime, or uses an adequate polyfill
This package bundles the [cbor](../cbor) package for easy use on the web. The following packages are bundled in as well, to reduce the degree of difficulty:
Plugin for node-cbor to add BigDecimal and BigFloat support. Requires bignumber.js
DNS over HTTPS and DNS over TLS
Runtime code for unicode-trie files.
Unicode line-breaking algorithm from UAX #14
Augmented Backus-Naur Form (ABNF) parsing. See RFC 5234.
hildjj's lint rules
Node.js Module for parsing .pcapng files and tcpdump output.
Lint rules for peggyjs projects
React Native pre-requisites for cbor
Get width of a Unicode string in fixed-width display cells, accounting for combining characters, emojis, flags, Hangul, East Asian Width, default ignorables, and a few more.
Extract fields from package.json into an ES6 module
Wrap lines using the Unicode Line Breaking algorithm from UAX #14
Small utils useful across all of my projects.
Evented parser based on a WASM-compiled version of expat
Description
Parse CBOR Extended Diagnostic Notation as defined by [draft-ietf-cbor-edn-literals-16](https://www.ietf.org/archive/id/draft-ietf-cbor-edn-literals-16.html) and some CBOR working group discussions.
A thin wrapper around [Pino](https://getpino.io/#/) to insulate multiple projects from the dependency, and to normalize a common pattern in those projects.
Command line tools to encode and parse data in the Concise Binary Object Representation (CBOR) data format (RFC8949).
Testing-only Certificate Authority (CA) for your local development environment ONLY. This is in no way suitable for production of any kind.
Serve files from a directory over HTTP/1.1 and HTTP/2, with live reload notifications over a websocket. It will automatically create self-signed certificates.
Interface to websequencediagrams.com
Grunt task for generating Codo documentation
Ensure eslint all rules are sorted, not deprecated, and included
Up the code coverage on your [Peggy](https://peggyjs.org/) grammars, ensuring that the generated boilerplate code is covered in your unit tests. This makes it easier to find places in your grammar that actually need to be tested.
Mock up a plain or TLS-encrypted TCP connection without using any actual network facilities or needing any permissions. This is useful for testing, particularly playing around with different TLS failure modes.
(in)dent XML to make it pretty
Builder code for unicode tries
ESLint-style parser for Peggy grammars
An [eslint](https://eslint.org/) plugin to check [peggy](https://peggyjs.org) grammars.
Scaffold a new project in the `@cto.af` style.
Parse HTTP headers from RFC 9110 (and a bunch of others) using the full ABNF.
feedly.com API
This project is a relatively-simplified approach to publishing multiple NPM packages from a monorepo. It handles these use cases:
`peggy-tracks` creates railroad track diagrams of [peggy](https://peggyjs.org/) grammars.
Download, cache, and parse files from the Unicode Character Database (UCD).
DNS over HTTPS and DNS over TLS
Create a mock DNS-over-TLS server based on [mock-tls-server](https://github.com/hildjj/mock-tls-server/).
Showing 50 of 84 packages